TL-WPS510U po upgrade już nie wstał


(system) #1

Witam !
Coś mnie podkusiło żeby zrobić update firmware do mojego serwera wydruku TP-Link TL-WPS510U. Mam model z 2010 r. v2.1. Znalazłem na oficjalnej stronie firmware dla v. 2 i postąpiłem zgodnie z instrukcją aktualizacji (krok po kroku poczynając od przywrócenia ustawień fabrycznych). Okazało się później po samoczynnym restarcie urządzenia że nie ma w ogóle emisji po WIFI sieci PS-WLAN (Ad-hoc) ani żadnej innej. Nie mruga ani się nie świeci w ogóle zielona lampka. Tak jakby część WiFi umarła. Komunikacja routera z drukarką przebiega normalnie. Można wydrukować test i ustawienia. Ci ciekawe mam teraz:
BSSIB: (puste)
Kanał: -1
adres MAC karty jest wlaśćiwy i nie uległ zmianie np. na 00-00-00-00-00.
Pytanie zasadnicze: Jak przywrócić urządzenie do życia. Jest już po gwarancji. Z ciekawości zaglądnąłem do niego do środka. Napisałem do suportu TP-Link już kilka dni temu ale nie raczyli odpisać.
Proszę o pomoc


(Marcin) #2

Próbowałeś resetować przyciskiem do ustawień fabrycznych?


(system) #3

No jasne. Robiłem już wszystko co można zrobić od strony użytkownika. Nie wiem czy nie będzie potrzebna ingerencja wgrania inną metodą


(CHACA) #4

Jeżeli jesteś w stanie teraz zalogować się na sprzęt to pokaż jaką wersję posiadasz aktualnie.


(system) #5

Cały czas się widać nie rozumiemy.
Żeby zalogować się do urządzenia, musi być jakakolwiek emisja WiFi z serwera,, a takowej nie ma. Na żadnym kanale, w żadnym trybie (ad-hoc, czy infrastruktura), w ukryciu czy widoczna. Nic z tego. Jest komunikacja tylko pomiędzy drukarką a urządzeniem, ale tylko w trybie TESTU, gdzie drukowana jest m.in. konfiguracja, z której jasno wynika, że kanał emisji WiFi = -1; a pole BSSID jest puste. Na wydruku, który otrzymuję napisane jest (nie mam tej strony przed sobą), że FW ma końcówkę 0015.


(CHACA) #6

Z jakiej strony pobierałeś to FW? Na naszej polskiej jest tylko 100814?


(system) #7

Pobrałem z polskiej strony tp-link'a. Zgadza się, ale w środku po rozpakowaniu zipa mamy: MPS48-TP-Link-6.04.48T-0015-124.bin.
I ten zaaplikowałem. I jestem jakieś 180 zł. w plecy, bo za tyle go 3 lata temu kupiłem. Zagląda tutaj ktoś z suportu tej firmy, bo odpowiedzi do dzisiaj nie otrzymałem co mam z problemem zrobić ?


(Marcin) #8

Wygląda na to że przy wgrywaniu oprogramowania znikło nagle połączenie bezprzewodowe i coś ucięło w konfiguracji. Trzeba by sprawdzić co to ma w środku (jaki procesor) możliwe że można coś wgrać przez interfejs szeregowy. Osobiście nic nie robiłem od środka z print server-ami.


(system) #9

Nic nie ucięło. Ponieważ miałem komunikat, że FW został wgrany z powodzeniem i sekundę później nastąpił restart urządzenia. gdyby coś ucięło, nagle by znikło połączenie, to urządzenie chyba by się nie zrestartowało, bo i jak dostało by komendę typu RESET. ?


(Marcin) #10

To jest twoje zdanie.
Rzuciłem twój temat do supportu TP-linka może w poniedziałek chłopaki coś odpowiedzą w temacie. Proszę o cierpliwość.


(CHACA) #11

Pytanko: jaki soft miałeś poprzednio - numer?


(system) #12

Nie wiem, nie pamiętam, nie zwróciłem uwagi. Przy aktualizacji nie pisało nic o podmianie wersji "z" "na".


(CHACA) #13

Czyli prawdopodobnie poszła wersja na wersję i wywaliło przy okazji bootloadera.


(Heinz) #14

Bootloader będzie cały, bo sprzęt jest wykrywany przez drukarkę. Jednak "sterownik" lub część firmware odpowiedzialna za WiFi nie została dobrze wgrana.
Można by się pokusić o rozebranie i poszukanie dostępu do terminala przez kabelek.
Jeśli to nie zadziała to chyba jedyna możliwość to wylutować flash i wgrać "czyjegoś" dumpa lub gotowe firmware w odpowiednie komórki.


(Marcin) #15

Tu jednak drogi Henryku potrzeba trochę doświadczenia, chyba potwierdzisz sam?


(Heinz) #16

Nie tylko doświadczenia ale i sprzętu. Nie wiem jaki flash tam siedzi, ale do niektórych trzeba użyć profesjonalnych programatorów.
Jeśli ktoś ma problem z lutowaniem niech odrazu odda do fachowca który by się tego podjął.

Sam kolega może tylko próbować z przyciskiem reset bo innego dostępu do tego urządzenia nie ma.


(CHACA) #17

Prawdopodobnie została wgrana wersja 100814 na taką samą. Resetem nic nie zadziała nawet 30/30/30. Innej wersji FW na chwilę obecną nie ma.


(system) #18

Co to jest 30/30/30 ???? O co chodzi ?


(system) #20

Dzięki - sprawdzę jutro
Znalazłem wydruk sprzed aktualizacji: Tam widnieje numerek wyższy: MPS48-TP-Link-6.04.48T-0020.
Czyli aktualizacja poszła w dół. Co ciekawe bez żadnego ostrzeżenia, że cofamy się z wersją.
Brak dat przy FW (na wydruku) nie pozwala jednak sprawdzić który FW jest starszy.


(CHACA) #21

Samemu raczej nic nie wywalczysz. Nie wiem czemu wywaliło ci po aktualizacji na niższą wersję? Tylko flash pamięci ratuje. Pamiętaj na przyszłość aby sprawdzać daty wychodzących aktualizacji na stronie producenta.