Gargoyle- problem z DLNA


(Szczurek259) #1

Witam
Zainstalowałem przed chwilą na TL-WR1043NDv3 najnowsze Gargoyle. Zrobiłem exroot, usypianie dysku i chciałem odpalić DLNA. Wszystko byłoby OK, gdy nie to że pokazuje mi tylko jeden folder z jednym filmem, a mam ich więcej nie wspominając o zdjęciach i muzyce. Co robię nie tak?


(Heinz) #2

Poczekaj narazie, możliwe że minidlna musi przeskanować dysk i dodać pliki do biblioteki.
Sprawdzę jak to zachowuje się u mnie.


(Szczurek259) #3

Czekam już 15 minut i dodało raptem ok. 15 filmów i chyba się zatrzymało. A co ze zdjęciami, ich wogóle nie wczytuje. Dziwne że FTP działa normalnie.


(Heinz) #4

Taki router to nie demon szybkości. Daj mu popracować.
Dysk już się uśpił czy nadal pracuje?


(Szczurek259) #5

DLNA wczyta parę filmów, dysk się usypia i chyba dalej nie pójdzie. Zaczekam jeszcze chwilę i zobaczymy czy coś wczyta więcej. A tak na marginesie to jaki rozmiar radiatora do niego dokupić?


(Szczurek259) #6

Wyłączyłem usypianie dysku. Dalej nic. Czy jest możliwe że najnowsze Gargoyle ma blokadę na 17 plików DLNA?


(Heinz) #7

U mnie ładuje więcej.
Zobacz sobie status na stronie http://192.168.1.1:8200 czy jeszcze pracuje czy coś nie chce

Możesz jeszcze połączyć się przez ssh i sprawdzić co masz w logu dlna za pomocą polecenia
cat /mnt/.minidlna/minidlna.log

Podczas pracy proces minidlna zużywa prawie 100% procesora routera:
image

ps ja użyłem WDR4300 który ma wolniejszy procesor ale ma 128MB RAM. Sprawdź jak u Ciebie z użyciem pamięci za pomocą komendy free

W Typie danych wybrałeś "bez określenia" czy wybrałeś np Filmy?


(Heinz) #8

Po godzinie pracy:
image


(Szczurek259) #9

A u mnie od 2 godzin jest 17 plików wideo i nie idzie dalej. A na jaką wersję Gargoyle masz? Może 1.9.2.5 ma taki błąd.


(Szczurek259) #10

Spróbuję zrobić downgrade do wersji 1.9.2.4. Jest gdzieś dostępna wersja 1.9.2.4?


(Heinz) #11

Proszę bardzo: gargoyle-1.9.2.4-ar71xx-tl-wr1043nd-v3-squashfs-factory.bin (7,8 MB)

Można tego użyć jako sysupgrade, jednak jeśli była zmiana wersji kernela to instalowanie innych modułów będzie utrudnione lub niemożliwe.

Ja używałem wersji 1.9.2.5 z eko.one.pl
Restartowałeś router? co masz w logu?


(Szczurek259) #12

Zainstalowałem na razie jeszcze raz 1.9.2.5. Zobaczę jutro jak poszło. Jak dalej będzie problem to napiszę.


(Szczurek259) #13

Nic z tego. Ponowne wgranie 1.9.2.5 nic nie dała. Zatrzymuje się na 17 plikach. Zobaczymy jutro, może przez noc coś wczyta.


(Heinz) #14

Masz jakieś ogromne pliki? może minidlna się wysypuje na nim.
Sprawdź ten log


(Heinz) #15

Możesz jeszcze spróbować dodawać udostępnione zasoby po 3 razy dodając osobno obrazy filmy i zdjęcia.


(Szczurek259) #16

Proszę oto logi


Pliki są duże i małe. Niektóre filmy mają po 2- 3 GB, a są które mają po 800 MB. Dodatkowo pełno zdjęć.


(Heinz) #17

Z logu wygląda ze proces skanowania po prostu się wyłączył. Jaki jest tego powód to nie wiem
u mnie po pojawieniu się:

[2017/10/22 17:18:51] minidlna.c:155: warn: received signal 15, good-bye
[2017/10/22 17:18:53] minidlna.c:1048: warn: Starting MiniDLNA version 1.2.1.
[2017/10/22 17:18:53] minidlna.c:348: warn: New media_dir detected; rebuilding...
[2017/10/22 17:18:53] minidlna.c:1089: warn: HTTP listening on port 8200

proces się restartuje i następuje ponowne skanowanie zasobów.
Stało się to po dodaniu nowego folderu do skanowania.

Możliwe że brakuje pamięci. Spróbuj wyłączyć na czas skanowania proces np samby ftp


(Jakub Danecki) #18

Ogólnie signal 15 oznacza, że ktoś grzecznie prosi proces minidlna o wyłączenie się (polecenie kill, ale nie kill -9) - może z powodu usypiania dysku albo innego planowego okresowego działania. Niestety jestem trochę za cienki w działaniu openwrt/gargoyle - warto może zapytać cezarego (z eko.one.pl - widzę, że już puściłeś tam pytanie, tylko za mało szczegółów dałeś), ale najpierw zobacz, czy w innych logach nie masz jakiegoś info, kto taki sygnał wypuścił w kierunku minidlna albo całego systemu.


(Szczurek259) #19

Wyłączyłem sambę, ftp i nic. Dziwne że zatrzymuje się na 17 plikach i nawet po całej nocy nie chce iść dalej.


(Heinz) #20

Bardzo dziwne, bo wg logu minidlna działał tylko 21 sekund.
Extroota robiłeś z GUI?
Sprawdź teraz jeszcze raz log, może się tam coś dodało.
Spróbuj też wydać komendy:

/etc/init.d/minidlna stop
/etc/init.d/minidlna start

aby zrestartować minidlna