WDR3500 - obcięcie pasma WAN do 10Mb/s


(Otyniak) #1

Witam,
czy ktoś miał może taki przypadek, że predkość połączenia routera od strony WAN zostaje obcięta do 10Mb/s? Takie zjawisko występuje w moim sprzęcie od kilku miesięcy. Sytuacje potwierdziłem zarówno przez bezpośrednie połączenie z innymi urządzeniami, jak i testami prędkości.
Przyłącze sieci mam radiowe (z anteny Nanostation Loco) do w/w routera skrętką - i przez TP-Linka dystrybucja w eter.
Jeśli chodzi o korzystanie z sieci to w 90% wystarcza mi 10Mb/s (chociaż powinienem mieć 20 i za tyle płace). Problem pojawia się, kiedy chcę coś obejrzeć w HD - wtedy przycięcie daje o sobie znać :frowning:
Mi to wygląda na jakąś awarię sprzętową portu. Mam taki pomysł, żeby wymienić jakieś (?) podzespoły z portu - analogicznymi, które są w portach LAN (wszystkie porty LAN są ok - 100Mb/s). Czy ktoś próbował podobnych operacji? Czy to ma sens? Ma ktoś może schemat tego lub podobnego urządzenia?
Niestety sprzęt po gwarancji i z zaaplikowanym OpenWRT - co skutecznie powstrzymuje możliwość uzyskania porady od producenta.
Za wszelkie odpowiedzi z góry dzięki


(Marcin) #2

Podłączając testowo przewód z WAN-a do karty sieciowej jaki masz link 10 czy 100Mb/s? TO samo sprawdź podłączając przewód z anteny do karty sieciowej.


(CHACA) #3

Bezpośrednio podłączony kabel do komputera daje normalne prędkości.


(Otyniak) #4

Na wyjściu z anteny jest 100Mb/s, a na WANie routera jest pokazuje tylko 10Mb/s. Co za tym idzie - komp podłączony bezpośrednio do wyjścia anteny działa z prędkościami > 10Mb/s (poprawnie).


(Marcin) #5

No to wygląda że masz uszkodzony (mechanicznie lub elektrycznie) port WAN routera.


(Otyniak) #6

Dzięki za odpowiedź; tak podejrzewam awarie sprzętową. :frowning:
Teraz mogę otworzyć sprzęt i spróbować coś z tym zrobić. Mogę na przykład pozamieniać jakieś elementy między portami (WAN i LAN), ale nie bardzo znam budowę portów i co za tym idzie nie umiem wytypować podzespołów, które mogły ulec awarii. Proszę o sugestie co jeszcze mógłbym zrobić.
Oczywiście biorę pod uwagę możliwość dalszego zepsucia urządzenia - prędzej czy później i tak skończy się wymianą na nowy...


(Marcin) #7

Mając na pokładzie OpenWRT czy Gargoyle możesz zmienić któryś z portów LAN na WAN właśnie - edytując plik network
Masz teraz coś takiego:

config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '1'
    option 'ports' '1 2 3 4 5t'
config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '2'
    option 'ports' '0 5t

Po edytowaniu powinno być:

config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '1'
    option 'ports' '0 2 3 4 5t'
config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '2'
    option 'ports' '1 5t'

Fizycznie porty numerowane są odpowiednio 0 - WAN, 1..2..3..4 - LAN, wystarczy w liniach portu wpisać odpowiednią wartość (option ‘ports’ ‘nr_portu 5t’)


(szopen) #8

jeśli mnie pamięć nie myli (od dość dawna nie mam już tego routera) to porty LAN są ponumerowane w sofcie 1,2,3,4
natomiast fizycznie oznaczone 4, 3, 2, 1
metoda opisana powyżej jest oczywiście OK
jakkolwiek ja bym pomyślał o podmianie kabla (tego idącego do AP nanostation) na inny - czasem w przypadku lekko uszkodzonego kabla zachodzą takiego typu anomalie - jedno urządzenie łączy się na pełnej prędkości, a inne nie potrafi wynegocjować niczego poza minimum


(Otyniak) #9

Skrętke już sprawdzałem - to nie jest przyczyna.
Mój plik "network" wygląda nieco inaczej (poniżej) - chyba troche inna zasada konfiguracji/numeracji, wskaż mi proszę które wartości powinienem zmienić, żeby zamienić WAN <=> LAN-1. Dzięki i pozdrawiam.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option dns '213.134.134.134'
config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.0.15'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	option dns '213.134.134.134'
	option peerdns '0'
config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'
config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0 1 2 3 4'

(Heinz) #10

Zmień na:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
config interface 'lan'
	option ifname '[b]eth0.1[/b]'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option dns '213.134.134.134'
config interface 'wan'
	option ifname '[b]eth0.2[/b]'
	option proto 'static'
	option ipaddr '192.168.0.15'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	option dns '213.134.134.134'
	option peerdns '0'
config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'
config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports [b]'0t 1 2 3'
config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 4'[/b]

Port LAN1 powinien być portem WAN


(Otyniak) #11

Dzięki, wieczorem przetestuje i dam znać wynikach.


(Otyniak) #12

Działa!
Teraz mam na porcie LAN1 wejście z anteny, a szybkość 100Mb/s.
Informacyjnie:
Port WAN nie stał się LAN1 (komputer podłączony do tego portu nie może ustanowić połączenia), dodatkowo dioda LAN1 sygnalizuje podłączenie/transfer WAN, a dioda WAN odwrotnie.
Ale to jest dla mnie nieistotne - ważne, że nowy WAN nie obcina szybkości łacza!
Dzięki wielkie!


(Marcin) #13

Zamknij watek jeżeli temat rozwiązany a w razie problemów zapraszamy ponownie.