TP-Link WR740N - problem z TTL


(Radar41) #1

Witam.
Rozumiem ze ten router nie ma fabrycznej (soft) możliwości podbicia TTL. Problem w tym, że pewien usługodawca zabezpiecza się dodatkowo w taki właśnie sposób, że czas życia pakietu TTL=1, a za routerem z wiadomych przyczyn jest już niestety próżnia.
Czy OpenWRT to dobry kierunek aby temu zaradzić ?


(CHACA) #2

Kierunek możesz obrać także na DD-WRT.


(Radar41) #3

Rozumiem, że DD-WRT to 1 plik z firmware, bez konieczności łączenia po SSH i instalacji jakiś GUI ? Nie żebym się bał OpenWRT ale w sumie to jeszcze ani jednym ani drugim się nie bawiłem..... nie żebym bał się linuxa, ale DD-WRT jest prostsze w instalacji, dobrze zauwazyłem ?


(CHACA) #4

Pobierasz od nas z forum dd-wrt i wgrywasz do routera poprzez skrętkę. Nic więcej nie potrzebujesz. Jak Ci się znudzi i będziesz chciał wrócić do firmware oryginalnego to zapraszam do wątku "Poradnik" w dziale Instrukcje tam w telegraficznym skrócie opisałem jak to zrobić.


(Radar41) #5

Ok, to jak już mam Cie na linii, to powiedz mi jeszcze na jaki adres należy się połączyć z TP-Linkiem przez TFTP w celu załadowania originalnego softu, gdybym go przypadkiem uwalił np złym softem ? Pytam hipotetycznie. ?


(CHACA) #6

Oczywiście adres LAN softu np: Gargoyle ma domyślnie 192.168.1.1.


(Radar41) #7

Ok, w sumie juz wygooglowałem. Chodziło mi o sytuacje w której zły soft uwala router i połączenie po adresie bramy jest niemożliwe. Mówiąc krótko trup.
Wtedy jak podaje google adres bootloadera to 192.168.0.5 :slight_smile:
Pzdro
Jak czegos nie bede wiedział to się odezwe.


(jimasek) #8

http://dd-wrt.com/wiki/index.php/TFTP_flash - tu masz jeszcze instrukcję z forum dd-wrt.


(Radar41) #9

Otrzymałem TP-LINKa WR740N V 4 .23 z załadowanym softem - przez kolege, który wymiękł na połączeniu SSH z routerem. Wgrany został jakis firmware - sam nie wie jaki, bo nie do konca był zorientowany co tak do konca robi :slight_smile:
Połączyłem się z tym routerem poprzez Putty - Telnet i skonfigurowalem hasło.
Następnie połączyłem się SSH i skonfigurowałem port WAN - interenet działa (był problem z DNSem). Pingi chodzą, wszytko gra.
Pobrałem za pomocą:
"opkg update" - jakąś paczke, następnie wklepałem : "opkg install luci" i niestety wyrzuciło komunikat, iż Luci instalation: Failed, generalnie brakuje jakiś plików.
No to zaczałem kombinować inaczej:
cd /tmp
sciągnałem: wget http://downloads.openwrt.org/backfire/10.03.1/brcm-2.4/openwrt-brcm-2.4-squashfs.trx
i chcialem uruchomić: sysupgrade -n openwrt-brcm-2.4-squashfs.trx
niestety błąd: Image check "platform check image" - failed
Mam poderzenie, że być może została wgrana zła wersja firmware, bo ten router ma wersje sprzętową v 4.23 - a kolega nie ma pojęcia co załadował.
Co robić, aby zainstalować LuCi ?


(jimasek) #10

Ewidentnie brakuje GUI skoro reszta działa. Próbowałeś z LuCI ?


(Radar41) #11

No właśnie próbowałem to zainstalować, ale nie potrafie. Jak to zainstalowac?
Czy poprawnym firmware dla tego routera jest: http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-factory.bin
I jak załadować tam LuCi ?


(Radar41) #13

Ok już działa.
Okazało się, że kolega wgrał nie ten soft. Tzn do 740N ale jakiś inny. Załadowalem poprawny, tj: http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-sysupgrade.bin, zaistalowałem Luci wg opisu i działa.
Ps. Gdzie tam jest opcja podbicia TTL ?


(jimasek) #14

Niestety nie bawiłem się w TTL na open-wrt :frowning:
Podobno trzeba dopisać do firewall.user ale czy działa to ci nie powiem.

 # opkg install kmod-ipt-ipopt iptables-mod-ipopt
 # echo "iptables -t mangle -I PREROUTING 1 -i eth0.1 -j TTL --ttl-inc 1" >> /etc/firewall.user
 # /etc/init.d/firewall restart

Tu jeszcze link z openlinksys - [url=http://openlinksys.info/forum/viewthread.php?thread_id=1660


(Radar41) #15

Jeśli chodzi o TTL + 1 to niestety powyższe nie działa.
Działa natomiast prostszy skrypt:

opkg install kmod-ipt-ipopt iptables-mod-ipopt
iptables -t mangle -I POSTROUTING -j TTL --ttl-inc 1

Niestety mam inny problem. O ile w static IP ładnie podając z łapki:

uci set network.wan.proto=static
uci set network.wan.ipaddr=192.168.2.10
uci set network.wan.netmask=255.255.255.0
uci set network.wan.gateway=192.168.2.1
uci set network.wan.dns='8.8.8.8 192.168.2.1'
uci commit network
ifup wan

działa bez zarzutów, o tyle ustawiając opcje DHCP Client niestety mi to nie działa.
Nie przydziela DHCP z automatu. Podejrzewam że IP przydziela, choć nie do końca jestem pewny, bo nie wiem jak to sprawdzić. Są jakieś pakiety wysłane/odebrane, ale DNSa na 100% nie pobiera. Jak to ustawić ? Chodzi mi o swoisty Dynamic IP z DHCP.


(jimasek) #16

Sam serwer DHCP w sieci działa poprawnie? Próbowałeś zmienić pulę adresów na LAN-ie?


(Radar41) #17

Server DHCP w sieci działa poprawnie, gdyż komp dla którego był dedykowany ten internet (MAC) dostaje adresy z automatu. Mac Clone Address też jest poprawnie zrobiony w WAN - ba nawet przypisałem do WANu MACa jeszcze raz dla pewności z linii komend po SSH.
Jeśli chodzi o pule adresów LAN to nic to nie dało, mało tego, spróbowałem na innym internecie(dostawcy) gdzie adres przydzielany również po DHCP jest prywatny z puli 88...... i też lipa. Nawet adresów nie pobiera. W obu przypadkach DHCP Client nie pobiera adresów IP (ISP przydziela w tym przypadku nawet bez Clone MAC Address.) . Coś jest nie hallo. Po Static IP działa pięknie.


(jimasek) #18

Gdzieś czytałem że któraś wersja openwrt miała problem że po zmianie statusu WAN na dynamic port robił się disable.


(Radar41) #19

Ok tylko sprostuje.
Jeśli chodzi o podbicie TTL, to jednak twój skrypt był prawidłowy, mój również podbił o dodatkowe TTL+1 ale tylko jeśli twój już był załadowany.
Zatem prawidłowy działający TTL to:

opkg update
opkg install kmod-ipt-ipopt iptables-mod-ipopt
echo "iptables -t mangle -I PREROUTING 1 -i eth0.1 -j TTL --ttl-inc 1" >> /etc/firewall.user
/etc/init.d/firewall restart
iptables -t mangle -I POSTROUTING -j TTL --ttl-inc 1

gdzie eth0.1 - to nazwa interfacu WAN ( w moim przypadku musiałem zmienić to na eth1). powinien pokazać się wpis "iptables..." w "Custom Roles" - w intefejsie LuCi.
Taka kombinacja zadziałała. Tak woli wyjaśnienia.