TP-Link TL-WR741ND OpenWRT jak wgrać LuCI?


(kazek31) #1

Ludziska zlitujcie się jak przez telenet wgrać tryb graficzny LuCI do tego ustrojstwa albo najlepiej wrócić do oryginalnego oprogramowania ??? Ja już nie daję rady ręce mi opadają >:( .
Nie doczytałem że OpenWrt ma tylko tryb tekstowy i teraz się męczę jak koń pod górę.
Próbowałem tak ;
Instalacja LuCI (interfejsu graficznego - GUI)

  # opkg update
  # opkg install luci
  # /etc/init.d/uhttpd enable
  # /etc/init.d/uhttpd start 

ale nie idzie
Jaki prosty serwer ftp ściągnąć i jak go skonfigurować ???


TL-WR941ND v4 Gargoyle 1.5.11.1 config problem
(Heinz) #2

TL-WR741ND ma tylko 4MB pamięci flash, dlatego graficzny tryb LuCI nie zostanie zainstalowany.
Co do OpenWRT możesz spróbować GargoylePL który ma domyślnie tryb graficzny.
Aby wgrać oficjalny soft musisz go mieć bez bootloadera. ( bez "boot" w nazwie pliku)
Czy router "ma" dostęp do internetu?


(kazek31) #3

tak ma dostęp po lanie do Internetu , bez większego problemu. Może byś mi kolego powiedział jaką komendą zainstalować z internetu bez ściągania obrazu na komputer ?


(Heinz) #4

Jeśli chcesz gargoyle PL to wpisz:

cd /tmp
wget http://eko.one.pl/gargoyle-pl/attitude_adjustment/ar71xx/gargoyle-1.5.10.14-ar71xx-tl-wr741nd-v[b]?[/b]-squashfs-sysupgrade.bin  #musisz określić wersję sprzętu i wstawić cyfrę po v np 741nd-v[b]4[/b]-squa
sysupgrade -n gargoyle-1.5.10.14-ar71xx-tl-wr741nd-v[b]?[/b]-squashfs-sysupgrade.bin
reboot

Jeśli chcesz oryginalne oprogramowanie to podaj wersję sprzętu. Przygotuję dla Ciebie plik bez bootloadera.


(kazek31) #5

Mam TL-WR741ND v2.4


(kazek31) #6

coś to nie idzie po wklepaniu adresu wyskakuje ;
wget: bad addres eko.one.pl
poza tym widze że internet chodzi przez tego apeka ale tylko niektóre strony.


(Heinz) #7

Sprawdź jeszcze raz czy router ma dostęp do internetu. Możesz to zrobić wpisując komendę:
ping onet.pl
Jeśli będzie odpowiedź to sprawdź jeszcze raz link.
dla wersji 2:
wklej wszystko do terminala:

cd /tmp
wget http://eko.one.pl/gargoyle-pl/attitude_adjustment/ar71xx/gargoyle-1.5.10.14-ar71xx-tl-wr741nd-v2-squashfs-sysupgrade.bin
sysupgrade -n gargoyle-1.5.10.14-ar71xx-tl-wr741nd-v2-squashfs-sysupgrade.bin
reboot

(kazek31) #8

coś mi to nie chodzi internet tak jakby jest ale go nie ma na apeku wczoraj coś sobie tam ściągał a dzisiaj nie a jeszcze po wpisaniu tej komendy wyskakuje że nieprawidłowy obraz .


(Heinz) #9

Czy jesteś pewien że masz router w wersji 2? sprawdź dokładnie.
Czy plik pobrał się w całości?


(kazek31) #10

tak wersje zaczytywałem z tabliczki znamionowej router mam od nowości a program się nie pobrał bo mi wyskakuje błąd strony www


(Heinz) #11

najlepiej pobrać na komputer. na komputerze postawić serwer http/ftp i wtedy połączyć komputer z routerem (komputer do portu LAN routera).
Komputer dostanie IP z serwera DHCP routera i pod tym IP będzie serwer http/ftp.
Wtedy zmienić linijkę na:

wget http://ip.komputera/nazwapliku.bin

i dalej

sysupgrade -n nazwapliku.bin


(kazek31) #12

coś będę próbował ale już po woli zaczynam tracić nadzieję że coś z tym zrobię. ???


(kazek31) #13

Kolego Heinc a weś zobacz na ten link i powiedz mi czy jak skonfiguruje serwer według tego jak tam jest napisane to mi pójdzie?


(Heinz) #14

Zadziała. Nie używaj ssl. Link będzie wyglądał troszkę inaczej.

ftp://[user]:[pass]@[ip.kompa]:[port]/plik.bin


(kazek31) #15

coś takiego ?

wget ftp://[user]:[pass]@[ip.kompa]:[port]/plik.bin


(Heinz) #16

Dokładnie.