TP-Link TL-WR740N V4 - jest Open WRT z poradnika, nie ma Luci


(mza) #1

Witam
Wgrałem goryla na początku, coś nie hulał więc przeszedłem przez tutejszy poradnik i zainstalowałem
pomyślnie OpenWRT.
Kiedy zabrałem się za instalację Luci, niestety pojawił się problem.
Po prostu na routerze nie ma na WAN internetu, który wcześniej był na oryginalnym oprogramowaniu TP-Linka.
Zmieniłem adres MAC na routerze przez PUTTY, jednak internetu nadal nie ma.
Pytanie 1.
Jak wrócić do oryginalnego oprogramowania dla tego routera
Pytanie 2
A może da się naprawić internet, i da się doinstalować wtedy Luci ?
Dane:
ISP - Publiczne IP ( przez DHCP )
Dostawa przez kabel: RJ45
Internet przydzielony do adresu MAC karty sieciowej komputera.
Adress MAC klonowanie: gdy dokupiłem ten router, użyłem klonowania i chodziło na oryginalnym oprogramowaniu.
Nie mam pojęcia co dalej robić, loguje się niby przez Putty, przeglądałem /etc/......network
i tam w eth1 WAN jest wpis o z moim NOWYM zmienionym MAC ale to i tak nie działa w sensie fizycznie.
Chyba będę musiał wrócić na oryginału :frowning: Proszę o instrukcję. Ponieważ mimo odpalenia
XAMPA i próby pobrania pliku a.bin, mam wpis: ZŁA WERSJA PLIKU.
Jestem taki zmęczony pare godzin grzebania, tyle czasu i nic...
Gdyby ktoś mi to ustawił zostałbym na tej Luci, interesuje się zmianami,
ponieważ potrzebuje lepszego firewala itp...


(Heinz) #2

Pewnie ze się da:


Wgrywając firmware bez bootloadera

Zamiast podać oryginalne firmware polecam podać gotowe openwrt z LuCI: [url=http://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-factory.bin

Jeśli chcesz naprawić konfigurację to podeślij plik /etc/config/network.
Możesz go wyświetlić w putty poleceniem: cat /etc/config/network i wkleić na forum.


(CHACA) #3

Jeszcze tylko pytanko: zmieniałeś adres LAN?


(mza) #4

Jedyne co zmieniałem to adres MAC na routerze.
Teraz przez WinSCP udało mi się zalogować do routera.
W katalog tmp, wrzuciłem plik: openwrt-ar71xx-generic-tl-wr740n-v4-squashfs-factory.bin
Muszę niestety się przełączać aby być tutaj na forum i ustawiać to urządzenie.
Czy plik który wgrałem do tmp na pewno jest taki jaki powinien ?
Gdzebiąc w katalogach routera widzę wpis w MODEL na końcu nie N, lecz ND.
Nie wiem czy to ma jakieś znaczenie.
Jeśli plik jest w porządku, rozumiem że teraz trzeba użyć z cmd odpowiedniej
komendy aby ten firmware się zaktualizował ?


(CHACA) #5

Literka D oznacza tylko to że router ma odkręcane antenki. Tak jak najbardziej możesz aktualizować.


(mza) #6

Witam ponownie.
Usunąłem ten post, ponieważ wgrałem nowy soft, Luci działa, DHCP poszło jest internet.
Udało się przez WinSCP. I reset routera ponad 20 sek według poradnika. Jestem ciekawy jak teraz
poustawiać wszystko. Ide potestować...
Także dziękuje za podpowiedzi, uff, już myślałem że nie da rady.


(CHACA) #7

Jak wszystko działa to temat zamykaj. Zapraszamy ponownie.