TP-Link TD-W8960N - Serwer na komputerze


(panaho) #1

Witam.
Posiadam router TP-Link TD-W8960N.
Do niego kablem podłączony komputer a na nim uruchomiony serwer (WebSerw) działąjący na porcie 81.
Na serwer mogę wejść za pomocą przeglądarki wpisując ip komputera i port 192.168.1.2:81 i wszystko działa.
Natomiast jeśli wpiszę w przeglądarce mój adres zewnętrzny i port (przykładowo 178.43.5.99:81) wejść na serwer już nie mogę.
W panelu konfiguracyjnym routera w zakładce Virtual Serwers przekierowałem port 81 na ip mojego komputera.
Co może być przyczyną? Co robię nie tak?

Pozdrawiam.


(szopen) #2

spróbuj wejść pod ten adres od strony internetu (z jakiegoś innego łącza), a nie ze swojego LANu


(panaho) #3

Z przeglądarki na telefonie mogę wejść. Jeśli telefon nie korzysta z wifi tego routera.
Jeśli w telefonie korzystam z wifi tego routera nie mogę wejść na serwer.
Czemu tak jest?
Wcześniej miałem router TP-Link TD-W8901G i nie pamiętam żebym miał tego typu problem.


(szopen) #4

nie każdy router ma tzw. loopback,
czyli z sieci LAN mogą nie działać odwołania po adresie WAN (i w ten sposób przekierowanych portach)
cel jednak osiągnąłeś - porty przekierowujesz po to aby do danego serwisu był dostęp z internetu
w sieci LAN pozostaje używanie adresu lokalnego


(panaho) #5

szopen, bardzo dziękuję za odpowiedź.
Rozumiem, że na tym routerze nie da się tego "jakoś obejść"?
Pozdrawiam.


(szopen) #6

wątpię, aby to było możliwe,
ale nie mam takiego routera, więc nie sprawdzę eksperymentalnie


(panaho) #7

OK.
Dzięki raz jeszcze.
Pozdrawiam