TL-ER6020 - dostep po publicznym IP z wewnątrz sieci nie działa

Witam,
zakupiłem router TP-LINK TL-ER6020 i mam problem z połaczeniem się do sieci po publicznym, stałym IP z wewnątrz sieci.

Mam w sieci serwer, na routerze przekierowane porty na wewnętnrze IP - w momencie podłaczenia z zewnatrz sieci (np LTE) wszystko działa - a kiedy probuje podłączyć się z komuptera w sieci lokalnej na zewnętrzne IP dostaje timeout.

Na poprzednim routerze (TL-WR841N) działało to od strzału.

Będę wdzięczny za pomoc i wskazówki co z tym zrobic/

Większość małych routerów TP-Link ma włączony NAT Loopback (i kilka innych nazw jeszcze jest) i nie można tego zmieniać. Natomiast w ER6020 takie rzeczy kontrolujesz samodzielnie i musisz to rozsądnie ustawić (zwłaszcza jak masz więcej WANów).
Musisz przeszukać interfejs i/lub instrukcję w poszukiwaniu NAT Loopback, lub cokolwiek innego co masz opisane w tym miejscu w wikipedii: https://en.wikipedia.org/wiki/Network_address_translation#NAT_loopback

Dzieki za odpowiedz,
probowalem np ustawic ONE BY ONE nat
tyle ze w przykladzie opisane jest jak ktos ma pule adresow IP - a ja mam tylko 1

w momencie jak w polu Translated IP wpisze wewnetrzne IP servera, ktory chce udostepnic - to telnet zaczyna odpowiadac ale nie mam internetu na tym serwerze.

One-by-one NAT to kompletnie coś innego (przypisywanie jednego IP z puli zewnętrznych do jednej maszyny w środku sieci, taki uproszczony DNAT, którego normalnie używasz.
NAT Loopback powoduje, że jak ktoś używa zewnętrznego IP w sieci wewnętrznej, to iptables (czy co tam w środku siedzi) wie, że ma użyć tego adresu jako aliasa dla IP widocznego w sieci wewnętrznej, a nie wysyłać go w powietrze (jak to się dzieje teraz).
Na szybko w Google nie znalazłem opisu jak to się włącza w tym routerze. Znalazłem tylko coś takiego:


Może faktycznie poproś o wersję beta, która ma tę funkcję dostępną/włączoną?

1 Like

dzieki za informacje!

  • tylko z tego co widze ja mam firmware 2.0.2 Build 20180702 Rel.59031 - powinno w niej to juz byc poprawione ?

EDIT: a nie to jest wlasnie wersja ktora ma blad :slight_smile: dobry catch! dzieki

Nowa wersja firmwaru pomogla, dzieki za pomoc @jakubd !!

Dzięki za potwierdzenie!