Mr3420 WDS bridge problem


(rpromin) #1

Hi there!
Long one but I tried to give all possible details to show the problem.
I have a serious problem with setting up WDS bride using MR3420 v.2.2. As a matter in fact I already tried using different routers (DLink, Technicolor) as primary router and MR3420 in WDS "mode" to extend WI-FI network, and it looks like there is something wrong with MR3420.
My configuration:
My primary router ip 192.168.0.1, secondary router ip 192.168.0.2, my laptop ip is 192.168.0.100. DHCP disabled on secondary router as it should be (I also tried to enable it just for testing purposes but it doesn't change anything)
WDS status says: Run - so far so good.
I am not able to ping even primary router when connected to secondary router, although in theory WDS is set up - its status RUN. The funny thing is that when I connect to primary router I am able to ping secondary router (MR3420) so looks like the bridge is set up indeed, but only one way ping is working.
I have a secure WDS setup (WAP) but I also tried insecure configuration - it doesn't change anything.
I restored factory settings couple of times to double check with clean configuration.
I tested newest published firmware (BETA) from TP-Link site and it doesn't change anything.
I run out of ideas what I can do more, apart from selling it as it looks it is just not capable to work in this mode properly.

IMPORTANT:
I tried similar configurations using WR1042ND having exactly same configuration set up and this one is working without any problems with every router I have, which makes me thinking that indeed the problem is on MR3420 side, what do you think?
Moreover I managed to set up properly working bridge when my primary was TP Link WR1042ND and secondary was MR3420, so it looks like MR3420 is able to set up proper bridge only with other TP-Link product, why????? TP-Link WR1042ND is able to set up bridge with any other router I have, so why MR3420 doesn't??

any help would be appreciated!
Best Regards
Roman


(Marcin) #2

This is normal symptom because WDS is specific mode support within a single brand. Connection with another router d-link, linksys etc, is difficult or not possible.


(rpromin) #3

Why it is working fine for TP-Link WR1042ND with any router.
TP-Link is not able to use same WDS implementation for all devices??? Strange for me.


(Marcin) #4

I told WDS is specific mode, because is only similar not the same in other brands implementation. This leads to your problems with connection between d-link and Tp-link in WDS mode.


(rpromin) #5

I understand that. And as you said it might be brand specific, but why this is model specific? I mean as it works fine between dlink and TP-LINK 1042ND why it is not working for the same dlink and TP-LINK MR3420, it looks like a sort of inconsistency within one brand.
Moreover TP-Link 1042ND is working fine not only with DLink but also with other brands while MR3420 is not working with anything apart from TP-Link, this is something I don't understand, it looks like step backwards comparing to 1042ND and probably a bug not like intended behavior.
thanks anyway.


(Marcin) #6

WR1042ND has Realtek chip (CPU) and here is the difference. Most routers from TP-link has Atheros processor and different firmware implementation. I don't know anything about TP-link firmware politics. We can't give you any advices, just works or not.


(rpromin) #7

Thanks for explanation!
At least I know that probably nothing I can do with it. I need to look for other solution.


(Marcin) #8

My proposition install Gargoyle on MR3420 and will make configuration with repeater. I have only polish tutorial here -


I have much better experiences with this mode in connection with other brands router.
Gargoyle has english interface also.


(rpromin) #9

thanks a lot!
Will try that.