MR-3420 - problem z Nat forwarding (Virtual server) przy FTP


(Sebastian) #1

Hej,
Od 10 miesięcy walczę z MR-3420, a konkretnie z jego wadliwym oprogramowaniem.
Posiadam stały publiczny adres IP (od dwóch dostawców dwa łącza i dwa publiczne IP), bez jakichkolwiek blokad portów itp itd.
Postawiłem na PC serwer FTP, przekierowałem porty - myślałem bajka.
O jakież było moje zdziwienie jak nie zadziałało (poprzedni router D-Link działał i przekierowanie dla FTP również). Połączenia i transfery plików na MR-3420 były nienawiązywane aby z powodzeniem dochodziło do transferu plików. O dziwo gdy podłączyłem FTP klienta od strony WAN lokalnie wewnątrz do MR-3420 za którym był serwer FTP do połączenia dochodziło. Nie działało tylko, gdy router był podpięty do Internetu. Jak wspomniałem, wykluczam problem u dostawcy Internetu. Sprawdzone na 4 różnych łączach, różnych dostawcach. Poinformowałem Support w Centrali TP-Linka w Chinach, zobaczymy co odpiszą. Polski Support potwierdził moje obserwacje, że router nie działa poprawnie. I jest to widocznie globalna usterka. Na każdym FW (oficjalnym i nieoficjalnym testowym) jest ten sam problem. Już mi normalnie "rynce opadajo"... Nie miałem podpiętych żadnych urządzeń do USB, a wewnętrzny serwer FTP był wyłączony.
Co o tym myślicie? Mieliście podobnie?
Pozdrawiam,
Sebastian


(Jakub Danecki) #2

Nie miałem tak w V1 i V2 - nie napisałeś o jakim modelu mówisz, a MR3420 to już chyba 4 albo 6 różnych urządzeń.
Jeżeli połączyłeś się od strony WAN z forwardowanym portem przez MR3420 to chyba jednak działa prawidłowo, bo to jest właśnie ostateczny test.

Nie napisałeś, jaki jest efekt podłączenia komputera z FTP prosto do operatora i sprawdzenia połączenia mimo, że "wykluczasz".

Nie napisałeś także, jak dokładnie forwarding ustawiłeś i jak testowałeś (FTP to dwa porty w trybie active i jeden w trybie passive).

Ogólnie proponowałbym użycie jakiegoś mniej porąbanego protokołu na start, np. http - ftp sam w sobie to jest wynazek programisty z puszczy, który nie doczytał RFC i nie przewidział istnienia NAT (co widać przy tym, że wymaga dwóch połączeń TCP na dwóch osobnych portach).


(Heinz) #3

Uruchomienie FTP z przekierowaniem nie jest proste. Dochodzi konfiguracja trybu passive i przekierowanie tych portów. W konfiguracji serwera trzeba też podać zewnętrzne IP dla trybu passive.

Jest stronka którą można testować połączenie do swojego serwera ftp. ( oczywiście robił bym to tylko w celu testowania "próbnej" konfiguracji:
https://ftptest.net/


(Sebastian) #4

Ostatnim czasem miałem rozmowę z TP-Link China. Potwierdzili mój problem. Połączyli się na TeamViever z moim komputerem. Są aktualnie w trakcie pracy nad rozwiązaniem problemu. Jestem z nimi w stałym kontakcie i myślę, że coś ogarniemy.