Dwa routery dostępność między nimi?


(tenobcy) #1

Witam posiadam TD-VG3631 jako główny router z adresem 192.168.1.1 i ten router udostępnia przez Wifi internet dla TL-WR710N z OpenWRT z adresem 192.168.2.1 i teraz moje pytanie w jaki sposób będąc połączony z TD-VG3631 dostać się do urządzeń/komputerów podłączonych z TL-WR710N?


(wojtek2803) #2

Ustaw tego TL-WR710N w jednej klasie adresowej tzn. tak skoro TD-VG3631 ma adres IP 192.168.1.1 to TL-WR710N ustaw IP 192.168.1.x( gdzie X to wartość poza zakres adresów DHCP TD-VG3631)


(tenobcy) #3

Już to próbowałem po tej zmianie nie ma internetu na drugim routerze czyli TL-WR710N


(wojtek2803) #4

W jakim trybie pracy masz tego TL-WR710N ?


(tenobcy) #5

Kient bezprzewodowy


(wojtek2803) #6

Nie wiem czy dobrze to rozumuje .Chcesz się zalogować np do TP linka TL-WR710N będąc podłączony do TD-VG3631?


(tenobcy) #7

Z TD-VG3631 do urządzeń/komputerów podłączonych z TL-WR710N. Bo do samego TL-WR710N z TD-VG3631 dostanę się po adresie jaki otrzymał


(Heinz) #8

Widzę że narazie jest on w trybie WISP lub Client Router.
Konfigurujesz WR710N przez jakieś GUI czy konsola?


(tenobcy) #9

Przez konsole próbowałem także z Luci ale zależy mi na jak najmniejszym obciążeniu i zużyciu pamięci także z Luci zrezygnowałem.


(Heinz) #10

podaj zawartość

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp

(tenobcy) #11
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option ula_prefix 'fd5c:e61f:463c::/48'
config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OpenWRT'
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar933x_wmac'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option channel '6'
        option htmode 'HT40-'
        option country 'PL'
        option txpower '20'
config wifi-iface
        option network 'wwan'
        option ssid 'mojasiec'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'XX:XX:XX:XX:XX:XX'
        option key 'mojehaslo'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

(Heinz) #12

zmień:
network:

config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        [b]option ipaddr '192.168.1.254'[/b]</blockquote>
wireless

config wifi-iface
        [b]option network 'lan'[/b]
        option ssid 'mojasiec'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'XX:XX:XX:XX:XX:XX'
        option key 'mojehaslo'
        option 'client_bridge' '1'

dhcp

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ignore '1'

Po restarcie WR710N nie przyzna on już adresów IP, bo zostało na nim wyłączone DHCP. Teraz TD-VG3631 będzie je przyznawał.


(tenobcy) #13

Ok dzięki niestety w tej chwili nie mogę sprawdzić ale dzięki za pomoc. Jak sprawdzę poinformuję czy działa tak jak powinno.


(tenobcy) #14

Nie działa niestety nic nie przydziela ba nawet zmuszony byłem do ponownej konfiguracji bo nie mogłem dostać się przez ssh czy telnet do routera :confused: Odpuszczam sobie dalszą zabawę :-[