Cannot connect to TPLink WR720N after disconnecting


(tekot200@gmail.com) #1

Yesterday I purchased a nw TPLink WR720N wireless router.
I connected it to my cable modem (comcast), cloned my laptop MAC address & I was online.
I surfed the internet for some time & after that shutdown the laptop & went out.
After an hour when I tried to connect again to wireless router, the laptop just does not connect.
Same for my android smartphone.
If I connect the ethernet cable to laptop, it works absolutely fine without any issues.
But cannot connect wirelessly.
I tried to connect to my neighbors wireless network & I can easily connect without any issues. Even if i disconnect & reconnect again, no issues at all.
The only way I can connect to my wireless router is after removing power cable, waiting for few seconds & powering it again.
After that I can connect to the wireless router.
I have opened a ticket with TP-Link & they asked me to change channel to a fixed value of either 1 / 6 / 11.
I tried that without any luck.
I have also updated the latest firmware on the router.
I request you to pls help me on this.


(Marcin) #2

What is your ISP (internet service provider)? Do you have latest firmware on your router? Please check on TP-link website. Give me screenshot from Wireless Settings .


(tekot200@gmail.com) #3

ISP is Comcast.
I upgraded router with latest firmware. TL-WR720N_V1_130719 (http://www.tp-link.com/en/support/download/?model=TL-WR720N&version=V1#tbl_j)


(Marcin) #4

Is it cable connection? Do you have any modem or router forom ISP?


(tekot200@gmail.com) #5

Yes its a cable connection.
I have my own modem. Motorola SB 6121.
I dont think its the modem problem. Coz even when I cannot connect wirelessly, I still can plug in the ethernet cable in the laptop & can connect without problems.


(Marcin) #6

Ok, I like to know everything about router and internet connection. This is very important in router configuration. Give us this screen shot form Wireless Settings.


(tekot200@gmail.com) #7

It seems like I have been able to accidentally resolve the issue.
Below is what I did.

  1. Reset the router.
  2. Rather than cloning PC mac address, I powered cycle modem as well & the first device I connected to it was router. As a result modem registered my routers factory mac address, rather than cloned pc mac address.
  3. During the initial setup, i kept all the default settings. channel (auto), mode (11bgn mixed), etc.
  4. Disabled WPS as have choosen WPA2-PSK security.
  5. Changed the time zone to EST.
    After doing all of above, it seems to work now. Am able to connect to wirless router, even after disconnecting. Both with my pc & phone.
    I will be observing this for next few days to ensure that the problem is resolved.
    Will post the update next week.
    Thanx for your help.

(Marcin) #8

We are waiting for results your configuration. Very important is change "Automatic" configuration for specific values in Wireless Settings.


(tekot200@gmail.com) #9

The connection problem seems to be resolved. But am observing something very strange.
After working perfectly fine for 2 days today suddenly I am seeing some lag in webpage loading. And in some cases even the error message saying "Unable to connect"
Infact accessing pages of router interface (192.168.0.1) was also very slow.
When I tried to connect the ethernet cable rather than wireless, everything seems to work absolutely fine. Pages loaded quickly (as used to happen in last 2 days on wireless as well). Access to router interface was also fast.
I tried changing channels from Auto to 11 & 6. But this also did not help.
I am attaching the wireless settings & error page while trying to access router.
Also am attaching a page where style sheet does not seems to be applied coz of this slow connection.
Pls help.