Brak zakładki nośnik USB 3420


(bartorux) #1

Witam :wink:
Nie mogę odszukać zakładki nośnik usb na routerze 3420. Musze coś doinstalowywać? Chce zrobić pendrive po SMB :wink:


(CHACA) #4

Jeżeli nie masz wgranego firmware alternatywnego Gargoyle to raczej nic nie wskórasz. Trzeba wgrać ten firmware. W oryginalnym oprogramowaniu TP -Linka nie ma opcji USB.


(bartorux) #5

Nie jest ze mną aż tak źle :stuck_out_tongue_winking_eye: Mam 1.5.10.12. Do tego aktywny hub usb. Drukarka już działa, ale chce do tego jeszcze SMB uruchomić, ale nie mogę odszukać zakładki Nośnik USB :wink:


(CHACA) #6

Coś mi się wydaje iż musisz uaktualnić co najmniej do wersji 1.5.10.2, bodajże od niej jest dodany sterownik do aktywacji portu usb. Kolejne wersje Gargulca są u nas na serwerze ftp do pobrania.


(Marcin) #7

Masz podłączony jakąś pamięć pod USB?


(bartorux) #8

Moja wypowiedź wyżej mam 1.5.10.12 :wink:
Tak pod NTFS nie był widziany, pod FAT też :slight_smile:
Wszystko jest pod Hubem aktywnym :wink:


(Marcin) #9

Jak podłączysz bezpośrednio pod router bez hub-a? To jest dysk czy pamięć elektroniczna?


(bartorux) #10

Pendrive


(Marcin) #11

W komputerze jest wykrywany poprawnie?


(bartorux) #12

Kilka sztuk wszystkie wykrywalne :wink:


(Marcin) #13

Czytałeś - [url=http://eko.one.pl/?p=gargoyle-fstab


(bartorux) #14

a ten wbudowany sposób?


(Heinz) #15

W Gargoyle PL dla routerów z USB i 4MB Flash nie zainstalowano domyślnie: "plugin-gargoyle-usb-storage" (obsługa samby/ftp/nfs)

Po instalacji tego dodatku pojawi się w GUI odpowiednia zakładka. Możliwe że braknie flash'u na tą operację.

Przez putty w terminalu wpisać:

opkg update

Jeśli nie zadziała instalator to jeszcze dopisać:

opkg install opkg

i jeszcze raz:

opkg install plugin-gargoyle-usb-storage

jeśli nadal nie dziala to pokaż co wypluje putty po komendzie:

opkg install plugin-gargoyle-usb-storage


(bartorux) #16
root@Gargoyle:~# opkg install plugin-gargoyle-usb-storage
Unknown package 'plugin-gargoyle-usb-storage'.
Collected errors:
 * opkg_install_cmd: Cannot install package plugin-gargoyle-usb-storage.

(Heinz) #17

komenda:
df -h


(bartorux) #18
Filesystem                Size      Used Available Use% Mounted on
rootfs                  384.0K    324.0K     60.0K  84% /
/dev/root                 2.5M      2.5M         0 100% /rom
tmpfs                    14.3M    512.0K     13.8M   4% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock3          384.0K    324.0K     60.0K  84% /overlay
overlayfs:/overlay      384.0K    324.0K     60.0K  84% /

(Heinz) #19

Masz dostęp do internetu przez router?
pokaż wszystko od momentu wpisania opkg update.


(bartorux) #20
root@Gargoyle:~# opkg update
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://eko.one.pl/attitude_adjustment/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/eko1.
Downloading http://eko.one.pl/gargoyle-pl/attitude_adjustment/ar71xx/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/gargoylepl.
root@Gargoyle:~# opkg install opkg
Package opkg (618-3) installed in root is up to date.
root@Gargoyle:~# opkg install plugin-gargoyle-usb-storage
Unknown package 'plugin-gargoyle-usb-storage'.
Collected errors:
 * opkg_install_cmd: Cannot install package plugin-gargoyle-usb-storage.
root@Gargoyle:~#

(Heinz) #21

widzę że coś pozmieniali.

Spróbuj tak:
cd /tmp
wget http://eko.one.pl/gargoyle-pl/attitude_adjustment/ar71xx/plugin-gargoyle-usb-storage/plugin-gargoyle-usb-storage_1.5.10.12-1_ar71xx.ipk
opkg install plugin-gargoyle-usb-storage_1.5.10.12-1_ar71xx.ipk

(bartorux) #22
root@Gargoyle:~# cd /tmp
root@Gargoyle:/tmp# wget http://eko.one.pl/gargoyle-pl/attitude_adjustment/
ar71xx/plugin-gargoyle-usb-storage/plugin-gargoyle-usb-storage_1.5.10.12-1_ar71x
x.ipk
Connecting to eko.one.pl (178.235.241.16:80)
plugin-gargoyle-usb- 100% |*******************************| 20766   0:00:00 ETA
root@Gargoyle:/tmp# opkg install plugin-gargoyle-usb-storage_1.5.10.12-1_ar71xx.
ipk
Installing plugin-gargoyle-usb-storage (1.5.10.12-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for plugin-gargoyle-usb-storage:
 * 	share-users * 
 * opkg_install_cmd: Cannot install package plugin-gargoyle-usb-storage.