Archer C50 problem z DHCP


#1

Posiadam Archer C50, podpięty do sieci zewnętrznej poprzez stały IP.
Udostępniam tylko WIFI 2.4, natomiast konfiguruję bezpośrednio po kablu.
DHCP włączone na zakres 192.168.17.100 - 199
Static IP ustalone dla kilku rządzeń powyżej 192.168.17.200
Aktualizacje wgrane tydzień temu 17.05.2018.

Problem mam z podłączeniem telefonu (różne modele samsung, nokia itd) - wrzuca mój telefon na IP 192.168.17.150 i nie mam połączenia z internetem podczas gdy inne urządzenia mają (table, laptop).
Przy restarcie czasem wrzuca mi telefon na pierwszy wolny IP z puli np 192.168.17.100 i wtedy mam internet.
Ustawiłem stały IP 192.168.17.220 dla mojego telefonu jednakże dalej wrzuca go na 192.168.17.150. Ponownie zaś gdy dam restart (aplikacja Tether) podpina mnie pod 220 (z internetem) lub 150 (bez internetu).

Sprawdziłem ustawienia DNS podając te od dostawcy i ogólne (8.8.8.8), wyłączyłem siec 5.0 i dla gości żeby nie przeszkadzały, adresy MAC sprawdzone i nie powtarzają się, ustawiałem na stałe BAND zamiast AUTO. Nic nie pomaga.
Wcześniej jeszcze miałem ustawione jedno urządzenie wpisane na stałe IP pod 192.168.17.150 i tez zamiast przydzielać to IP do tego urządzenia wrzucało mi tam telefon.

Nie wiem już co gdzie sprawdzić.


(Heinz) #2

Witam,

Problem jest z jednym czy wieloma telefonami? Wszystkim daje ten sam IP?

Jak robiłeś aktualizację to przywracałeś zapisane ustawienia czy konfigurację przeprowadziłeś od nowa?

Ustawienie stałego IP w telefonie ( nie w dhcp routera) pomaga?


#3

Problem dotyczy różnych urządzeń. Zarówno telefonów jaki laptopów przy czym na telefonie cały czas.
Robiąc aktualizację nie musiałem przywracać ustawień ani konfigurować.
W telefonie (Samsung xcover2) nie ustawiałem stałego IP (nie wiem czy umiem bo nigdy nie sprawdzałem).
Ustawiłem właśnie statyczny adres 220 taki jak wpisany jest do routera i po podłączeniu nie ma dostępu do Internetu. Jak włączę dhcp na telefonie dostaje 150 i dalej to samo.

Znaczące jest że brak dostępu do internetu dzieje się zawsze gdy przydzieli adres ip od 150 w górę. Przypisuje różne ip ale zawsze gdy jest powyżej 150 to nie ma internetu.
Przy czym nie chciałbym aby każdy telefon, dla każdego gościa był ustawiany przez stałe IP jak mnie odwiedza... nieprawdaż?


(Jakub Danecki) #4

Możliwe, że przy przypisywaniu MAC adresów gdzieś coś namieszało się i zamiast sztywnego przypisania jest tam jakaś gwiazdka - wiele urządzeń przypisuje się do jednego IP (tego 150).
Może próbować usunąć wszystkie przypisania DHCP na sztywno w routerze, ale mogą być jakieś niewidoczne - i lepiej zrobić po prostu przywrócenie ustawień fabrycznych.


#5

Obecnie nie mam problemu że przypisuje mi urządzenie do tego samego adresu. Wyrzuciłem poza pulę 100-199 to co mam na sztywno (od 200 do góry). Problem że przypisuje mi urządzenia do ip od 150 i w górę i nie daje mi na nie dostępu do internetu.
Co ciekawe wczoraj przypisałem w routerze na sztywno ip do telefonu na 220, na telefonie wyłączyłem dhcp i też ustawiłem na sztywno 220 i... dalej nie miałem internetu. Restart routera i dalej nic.
Zostawiłem sztywne ip na routerze 220 i włączyłem na telefonie dhcp i przypisuje 150 i nie ma internetu.
Restart i przypisuje 220 i internet jest...

Podkreślam że nie dzieje się to z jednym urządzeniem ale różnymi telefonami i laptopami.


(Jakub Danecki) #6

Jest to na tyle abstrakcyjne zachowanie, że najlepiej zrobić reset sprzętowy do stanu fabrycznego.


#7

Ok. Potwierdzone moje przypuszczenia o poziomie abstrakcji. Dam znać jaki wynik.


#8

Zrobiłem reset routera do ustawień fabrycznych. Wszystko wklepałem od zera raz jeszcze. Dalej to samo.
Laptop dostaje ip150, mój telefon 151, żony 162... każdy nie ma dostępu do internetu.
Statyczne IP są przypisywane ok i mają dostep (np repeater - inny router tplink działający na wifi)

Postanowiłem zmniejszyć pule na DHCP i jest 100..140 i co ciekawe WIFI dalej przydziela urządzeniom adresy powyżej 150 bez dostępu do internetu. Zakładam więc jakiś problem z ustawieniami wifi 2.4.
Jakieś pomysły? Dlaczego dhcp z wifi leci z numerami z poza puli?


(Heinz) #9

Pokaż zakładkę jak skonfigurowałeś DHCP

Jeśli możesz to też podeślij wynik z IPCONFIG /ALL z niedziałającego laptopa


(Jakub Danecki) #10

Obstawiam w takim razie, że namieszałeś także w końcówkach - np. dodałeś statyczne adresy awaryjne, które mają być przydzielane w przypadku braku dostępu do DHCP. Możliwe, że masz w sieci inne urządzenie, które próbuje przydzielać adresy IP.


(Heinz) #11

Pewnie kolega już się zorientował że DHCP z innego sprzętu ( repeater?) przydziela IP dla tych niedziałających urządzeń.


#12

No niestety nic z tych rzeczy. Ten inny sprzęt jedynie łączy się z moim routerem C50 i podaje sygnał po kablu do stacjonarnego komputera. Pula na tym sprzęcie jest 192.168.117.100..199 więc zupełnie inna. Ponadto na tym innym sprzęcie mam wyłączone wifi więc nawet nie można się podłączyć.
Wracając zaś do pytania przesyłam zrzuty ekranowe. Zauważyłem że błędne są Brama, Serwer DHCP i Serwer DNS 192.168.17.245 zamiast 192.168.17.1
001


(Heinz) #13

A co to za urządzenie z adresem IP 192.168.17.254?
Repeater? To on rozdaje adresy IP.
Możesz mu wyłączyć DHCP albo przestawić w nim adresy IP bramy domyślnej oraz DNS na 192.168.17.1.


#14

Repeater to inny router TPLINK który łączy się po wifi z C50. Ma on stałe ip jak w ostatnim zrzucie 192.168.17.210. Do niego podłączony jest wyłącznie stacjonarny komputer po kablu. Zakres IP ustawiony na DHCP na nim to 192.168.117. 100...199 (sto siedemnaście!). Brama itd są 192.168.17.1 (siedemnaście). Ponadto jak wspomniałem mam na nim wyłączone wifi (DISABLED) całkowicie (SSID jest oczywiście też inne).

Zrzut ipconfig wysłałem z laptopa podłączonego po wifi do C50. Ma przydzielone z dhcp ip 192.168.17.152 czyli z C50 ale poza pula DHCP!
W samym C50 po zalogowaniu jest tak:

  • w zakładce DHCP Clients List nie ma przypiętego laptopa
  • w zakładce Wireless statistics jest podpiety laptop (wg adresu MAC)

Odrzucam więc że mój inny sprzet jakkolwiek bruździ chociaż wieczorem odepnę fizycnie zasilanie i sprawdzę czy coś się zmieniło.
Jak dla mnie WIFI przydziela adresy zupełnie spoza DHCP ale nie wiem zupełnie dlaczego. Co ciekawe czasem jak zrestartuję to przydziela i wtedy sa 192.168.17.100, 101 itd... Dzieje się to na telefonach, laptopach, tabletach bez wyjątku ale tylko po wifi.
Ciekawy jest fakt że kiedy przydziela adresy od 150... to nie ma internetu a Brama itd są 192.168.17.245 (dwieścieczterdzieścipięć).

Pozostając do dyspozycji proszę o dalsze wsparcie i pomysły.


(Heinz) #15

Jak już zauważyłeś zostaje przydzielona brama 192.168.17.254
a komputer przyznał się że dostał to z serwera DHCP o adresie 192.168.17.254
Nie wiem co tam jest podłączone ale to coś ma włączone DHCP i to on rozdaje AP

WiFi tutaj nie ma nic do tego.

Możesz na próbę odłączyć wszystko co jest podłączone pod porty LAN oraz wyłączyć repeatery i wtedy sprawdź jakie IP dostaniesz.


#16

Odłączyłem od napięcia inny sprzęt czyli tplink routerek od komputera stacjonarnego. Dalej to samo. Zrobiłem ping 192.168.17.245 i dostałem olśnienia. Instalatorzy od centrali alarmowej założyli mój stary router airlive jako switcha.
Podłączyłem się do niego bezpośrednio i to on jest sprawcą całego problemu. Jako jedyne urządzenie jest bezpośrednio kablem wpięty do C50 (do portu 1) a potem do niego trzy panele (do portów 2, 3, 4).
Ten airlive miał i ma wyłączone WIFI. natomiast ma włączone DHCP właśnie od 150. Niestety nie wiem i nie rozumiem jeszcze dlaczego przejął przydzielanie IP? Panele wpięte do niego uzyskiwały stałe IP wg DHCP z C50. Drugi router tplink po wifi dostawał też stały IP. Natomiast telefony, tablet czy laptopy już nie. One dostawały IP z puli airlive.
Teraz też przestawiłem IP tego airlive na stały 192.168.227.1 i dalej przejmuje i nadaje po swojej puli DHCP 192.168.227.100..110 adresy urządzeniom z wifi z C50.
To nad czym teraz siedzę to ustawienie tego airlive żeby działał jak zwykły switch.

Dziękuję za wsparcie. Mam nadzieję że z tym airlive to już pójdzie. Mam też nadzieję że wkrótce odwdzięczę się innym użytkownikom swoją pomocą!


(Heinz) #17

Tego Airlive możesz ustawić najlepiej na 2 sposoby:

  • zostawienie włączonego serwera DHCP jednak wpisanie mu bramy domyślnej na 192.168.17.1
  • wyłączenie serwera DHCP na nim

Domyślam się że łatwiej będzie przypisywać adresy IP na jednym urządzeniu więc polecam ustawić na airlive IP np 192.168.17.254 oraz wyłączyć serwer DHCP.


#18

Ustawiłem mu stałe IP 192.168.227.1 i wyłączyłem IP.
Hula jak Stefan podczas olimipiady.
WNIOSKI - zawsze sprawdzaj WSZYSTKIE urządzenia. Odłącz wszystko co masz i powoli podpinaj żeby sprawdzić co bruździ.

Jeszcze raz dziękuję - można zamknąć temat. Dobranoc :slight_smile: